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Crosslight 器件仿真基础学习 step08 CrosslightView 操作指南 

编写：邱玮 

校验：盛阳 

CrosslightView 图形工具(GUI)用于查看和分析 Csuprem/Apsys/Pics3D

等软件的输出文件，具有优秀的器件结构内部剖析展示能力和器件性能曲线分析

能力。经过超过 15 年的不断完善，能够稳定高效地帮助器件研究人员得到专业

级的图形结果。 
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第一部分 界面介绍 

1.1 界面介绍>界面布局 

 

 

整个界面主要由四部分组成： 
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 左上区域为常用的工具栏按钮面板， 方便用户迅速定位一些常用的操作按

钮，如 open std file，open str file，1d-cut，旋转、放大、平移等功能； 

 左下方显示了当前器件的材料列表，列出了每项材料的编号、名称、颜色、

类型及显示透明度； 

 屏幕的中间部分为主要显示区域，材料分布和各种参数曲线都显示在该区

域； 

 屏幕右方的长列表列出了当前显示器件的所有参数变量名，用户可以通过点

击参数名称切换到想要查看的参数分布图进行显示。用户也可以在列表上方

的搜索框内输入变量名称来迅速跳转到想要选择的变量名。 

1.1.1 界面介绍>界面布局>常用工具栏按钮 

1.1.1.1 界面介绍>界面布局>常用工具栏按钮>Open Str File 

 

该按钮用于快速打开指定的 str 文件（Csuprem 工艺仿真所保存的结构文

件），用户只要在对话框中选择一个 str 文件并按下确定按钮，与该 str 文件所关

联的器件的材料分布就会被显示在屏幕上，如下图所示： 
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1.1.1.2 界面介绍>界面布局>常用工具栏按钮>Open Std File 

 

与 Open Str File 的功能类似，该按钮用于快速选择并打开一个 std 格式
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（Apsys 和 Pics3D 器件仿真的输出文件）的文件。 
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1.1.1.3 界面介绍>界面布局>常用工具栏按钮>Mesh On 

 

用于显示或隐藏三角形网格线的绘制，在缺省情况下 Crosslightview 会显

示网格线，如下图所示： 

 

“mesh on”按钮为选中状态时显示三角形网格线 

 

如果取消选中“Mesh On”选项则不显示网格线： 

 



 

 

第 9 页 共 238 页 

第 9 页 共 238 页 

 

“mesh on”按钮为非选中状态时不显示三角形网格线 

1.1.1.4 界面介绍>界面布局>常用工具栏按钮>Electrode 

 

用来显示或关闭显示电极的绘制（仅用于 std 文件）,如下图所示。当

electrode 按钮处于选中状态时，电极将被显示在器件的相应位置： 
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1.1.1.5 界面介绍>界面布局>常用工具栏按钮>Boundary 

 

用来开启或关闭显示不同编号材料的边界线，下图所示为打开和关闭边界显

示的对比图： 
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显示材料边界线 ( boundary on ) 

 

不显示材料边界线（boundary off） 
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1.1.1.6 界面介绍>界面布局>常用工具栏按钮>1D Cut 

 

1D Cut 按钮用来在某个变量 2D 分布图上 cut 出一条 1D 分布曲线。 指定

一个起点和终点，生成一条 1D cut 线，横坐标为 cut 线上各点离起点的距离，

纵坐标为变量在 cut 线上的值。生成 cut 线有两种方法： 

1） 任意拖动法 

在屏幕上选取一个 cut 线的起始点(sp)并按下鼠标左键，按住鼠标进行拖动

直到终点(ep)的位置，一条 cut 线便形成了，如下图所示： 

 

 

 

 

松开鼠标后系统会自动计算出这条 cut 线上的变量点的值绘制出 1D Line 的
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分布曲线，如下图所示为 Net Doping 的 1D Cut 曲线： 

 

X 方向代表每个 cut 点距离起点位置的距离，Y 方向代表每个 cut 点的 Net 

Doping 值。 

 

2） 坐标值输入法 

当用户按下 1d cut 按钮后，在显示区域的标题栏下方会出现一个输入框工

具条，如下图所示： 

 

用户可以在输入框中输入 cut line 的起点和终点的坐标，然后按右方的蓝色

箭头按钮进行 cut。这种方法的优点是用户可以精确控制起始点和终点的位置，

从而得到更精确的 cut 结果。 
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1.1.1.7 界面介绍>界面布局>常用工具栏按钮>2D Cut 

 

用来查看三维器件内部某个二维面上的变量分布，可以是 xy、xz 或 yz 等多个方

向上的 cut 面。首先用户可以在以下对话框中选择需要查看的选项： 

 

 

XY Original Plane 

用来查看组成三维器件的 z 方向上的 xy 原始面，用户可以在对话框的”z=”下

拉框中选择需要查看的面的序号。如下图所示的三维器件由九个 xy 面组成，分

别为 plane 1 – plane 9： 
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当用户选择 plane 1 时就会显示第一个面的原始三角形 mesh： 

 



 

 

第 16 页 共 238 页 

第 16 页 共 238 页 

 

 

用户选择 plane 9 时显示第九个面的原始三角形 mesh： 
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XY Cut Plane 

如果用户想要查看两个 xy 原始面之间的二维切面，就需要在这两个原始 xy 

plane 之间进行 cut，在上述的三维器件中，如果我们想要在 z=1.0 和 z=1.25

两个原始面之间进行 cut，就必须先选中对话框的第二个选项：xy cut plane，

然后在后面的输入框中输入 z=1.2，系统就会 cut 出 z=1.2 处的二维 cut 面，如

下图所示： 

 

 

 

系统会根据该 Z 值(1.2)前后相邻的两个面（z=1.0 和 z=1.25）的三角形数据来

计算得到相应的 cut 面的三角形数据，显示如下： 
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XZ and YZ Plane 

接下来的两个选项是查看 xz 方向和 yz 方向上的 cut 面，当显示 XZ cut 面时需

要指定固定的 Y 值，显示 YZ CUT 面时需要指定固定的 X 值。以下图所示的三

维器件为例： 
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用户选择查看位于 x=8 处的 YZ cut 面，在对话框中选择“YZ Plane”选项，输

入 x=8： 
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进行计算后显示 x=8 处的 YZ Cut 面： 

 

 

以下为 y=-5 处的 XZ cut 面的显示结果： 
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Filling Volume Plane 

对于包含 filling volume 数据的三维器件，用户可以查看 filling volume 在 z

方向上的 cut 面，如下图所示的三维器件： 
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用户在对话框中选择查看 z=0.6 处的 filling volume cut 面： 
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得到的显示结果如下： 

 

1.1.1.8 界面介绍>界面布局>常用工具栏按钮>3D Cube  

 

该按钮用于显示当前变量属性的三维 Cubic 结构。比如某个器件结构的

potential 变量在二维平面上显示如下： 
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当点击 3d cube 按钮后，potential 变量在三维结构上的分布被打开： 

 

1.1.1.9 界面介绍>界面布局>常用工具栏按钮>Axis Scale 

 

为了配合屏幕的高宽比，缺省情况下 Crosslightview 中所有器件的长宽尺寸都
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按照屏幕比例进行缩放，以达到更好的显示效果。在某些情况下用户可能想要看

器件的原始尺寸比例或者按照自己的喜好设置长宽比，这时就要用到工具栏面板

中的“Axis Scale”按钮进行设置。以下面这个器件为例，缺省情况下 x 和 y 轴

的比例和屏幕长宽比例一致： 

 

点击“Axis Scale”按钮，出现以下对话框： 
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Original Scale 

第一个选项 Original Scale 是用器件本身原有的长宽比进行显示，如下图所示： 
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可以看出 original scale 与缺省的显示方式在缩放比例上有明显的区别，它反映

了器件原始的大小尺寸比例。 

 

Fit to Screen 

Fit toScreen 选项对器件的长宽比按照屏幕尺寸进行缩放，也就是缺省的显示方

式，这种显示方式因为与屏幕大小相匹配，所以在视觉上会感觉相对比较舒服。 

 

Rescale Factor 

这个选项是用来缩放坐标轴的范围，注意是坐标轴的范围而不是器件本身的尺

寸。如上面的例子，假如我们在对话框中输入 rescale factor 为 x=2，y=2，横
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坐标 x 轴的范围会被放大两倍，而 y 轴的坐标范围也会被扩大两倍，如下图所示： 

 

 

 

Resize Factor 

最后一个选项 Resize Factor 是用来调整器件本身的长宽比的，假如在对话框中

输入 x=1，y=2，则表示纵坐标 Y 轴的长度是横坐标 x 轴的 2 倍。如下图所示： 
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1.1.1.10 界面介绍>界面布局>常用工具栏按钮>Property 

 

Property 按钮用来调整一些图像的显示属性，如坐标轴的颜色、线宽、字体和

网格的颜色等等。当选择这个按钮时会出现如下对话框，每一个 tab 页代表某个

类别的属性，以下会逐个进行说明： 

1）Axis Property 
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Axis Property 属性页里面包含了所有与坐标轴相关的属性： 

line color 代表坐标轴的颜色，用户可以通过点击“change color”按钮来改变

坐标轴的颜色。 

line width 用来调整坐标轴的线宽，缺省为 1 

复选框”Show Axis Line”用来打开或关闭坐标轴的显示。 
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Label Color 代表坐标轴刻度值的颜色，用户可以通过点击旁边的”change 

color”按钮来调整刻度值的颜色。 

Label Font 用来设置坐标轴刻度值的字体。 

复选框”Show Axis Lable”用来显示或隐藏刻度值。 

Flip X Axis 用来反转横坐标 X 轴。如下图所示的二维图像，缺省情况下 x 方向

自左向右逐渐变大： 

 

 

假如用户选中“Flip X Axis”选项，则 x 方向上的坐标值会由大到小排列，整个

图像也会在 x 方向上进行反转，如下图所示： 
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Flip Y Axis 用来反转纵坐标 Y 轴，和 Flip X Axis 用法一致 

Set Axis Range 

用户可以通过设置横坐标和纵坐标的范围来放大显示物体的某个局部区域。如下

图所示的图像： 
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假如用户在对话框中输入 x 的显示范围从 2 到 8，Y 的显示范围从-2 到 0： 

 

那么在这个范围内的三角形数据会被放大显示到屏幕上，如下图所示： 
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Axis Increment 

用来设置坐标轴的刻度间隔，缺省情况下系统会根据坐标轴的长度自动计算刻度

的间隔大小，如下图：x 横坐标的间隔大小为 2 

 

假如用户想要自由设置坐标轴的刻度间隔大小可以到 Axis Incremant 里面输入

想要的间隔数值，比如设置 x increment=1： 
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系统会自动调整横坐标刻度的间隔大小为 1，如下图所示： 

 

Log Scale 

该功能只适用于 data line 的显示，如 scan bias line, spectrum data, LED data

等。选择 log scale 复选框可以对横坐标和纵坐标分别取 log10。如下图所示的

scan bias line ： 
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横坐标的范围为 0 - 7E-11，如果选择对 x 轴取 log： 

 

 

得到的结果如下： 
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Abs Scale 

对坐标轴取绝对值，如上述的 scan bias data line 的纵坐标范围从-0.8 到-0.1，

选择对 Y 轴取绝对值： 

 

 

 

得到的结果如下： 
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2）Grid Line 

Grid Line 页面用来设置背景网格线相关的一些绘制属性。通常我们在绘制 scan 

bias、spectrum data 或者 1d cut line 等数据线时会以垂直交错的网格线作为

背景，以便更好地显示点与点之间的空间距离感，如下图所示： 
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在缺省情况下，grid line 不被显示，只有当用户在 property->grid line 对话框

中选中”show grid line”选项时，网格线才会被选中，如下图所示： 
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其他几个和 grid line 相关的绘制属性包括： 

Background color: 绘制背景色，缺省为白色，用户可以点击旁边的 change

按钮修改背景色。 

Grid Line Color: 网格线颜色，缺省为浅灰色，用户可以点击旁边的 change 按

钮修改网格线颜色。 

Grid Line Type：网格线类型，分实线和虚线点两种。 

Grid Line Thickness：网格线线宽，缺省为 1 

Grid Space：网格线在 x 方向和 Y 方向上的间隔距离，缺省为坐标轴相邻刻度

之间的间隔距离。 

假设我们将上面显示的 1d cut line 改成黑色背景，将网格点颜色改为绿色，网

格密度增加一倍，则会得到如下结果： 



 

 

第 42 页 共 238 页 

第 42 页 共 238 页 

 

 

呈现的效果如下： 

 

3）Color Bar 
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在屏幕显示的右方有一个 color bar，用来显示当前图像所使用的颜色值和参数

变量值之间的对应关系。如 cubic contour fill 或 2d contour fill 的 color bar 如

下图所示： 

 

 

 

Color bar 的最上方显示的是变量或参数的名称（potential）,下方是一个颜色

渐变条，每一种颜色代表一个参数值范围，通常蓝色代表最小值，随着参数值增

大逐渐向红色过渡。用户可以通过点击 property -> color bar 来修改 color bar

的显示属性。 
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Show Color Bar : 该复选框用来显示或隐藏 color bar 
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Use Grey Color Range:  

使用灰度阶梯色系来显示器件颜色。 用户可以在 property->color bar 里面选

中复选框”Use Grey Color Range”，图像便会以灰度色彩来呈现，如下图所示： 

 

 

Bar Area Size 

缺省情况下 color bar 的区域大小为 1，用户可以在 bar area size 里面调整

color bar 的大小。如下图所示的是上面那个示例的 color bar 调整为 0.5 以后

的大小： 
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Set Font 

用来修改 Color Bar 里面用来显示的字体，包括标题字体(Title Font)以及刻度字

体（Label Font），可以分别修改。 

Bar Title 

用来设置 Color Bar 的标题。可以设置两个标题（Title 1 和 Title 2）,例如在上

述例子中 Title 1 为空白，Title 2 为代表变量名称的 potential，我们可以在对

话框中设置 Title 1 为“Cubic Contour”，Title 2 改为“Parameter”： 

 

 

效果如下图所示： 
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Set Color 

设置 Color bar 的显示颜色，包括标题颜色（title color），背景颜色（background 

color）,边框颜色（boundary color）,刻度标识颜色（Label Font Color）。如

下图为修改颜色后的效果图： 
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Orientation 

Orientation 用来设置 color bar 的排列方式，总共有三种方式： 

 

 

Vertical Style ：color bar 以垂直排列的方式显示在屏幕的右侧，也是目前缺

省显示的方式。 
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Horizontal Style 1：水平显示方式，color bar 以水平条的样式显示在屏幕的

下方，如下图所示： 

 

Horizontal Style 2： 

也是以水平的方式显示 color bar，和 horizontal style 1 有所区别的是刻度标

识的排列方式有所不同，如图所示： 
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Descriptions：在 Color bar 对话框的最后一栏 Description 是每一种颜色所代

表的材料名或变量值的标识列表，如下图所示： 
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Description 列表里显示了 color bar 的每种颜色所代表的材料名称，我们可以

双击列表框里的材料名称进行修改： 
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比如分别在 Si 和 SiO2 的后面加上”material 1”和”material 2”，那么屏幕

上显示的 color bar 描述标识也就相应地做出了改动： 

 

 

4）Boundary Line 

Boundary Line 是 指 材 料 边 界 线 ， 缺 省 情 况 下 不 显 示 ， 用 户 可 以 到

property->boundary Line 对话框属性页中选中“Show Boundary Line”复

选框进行显示： 
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每一个 xy plane 的材料边界线都会显示在器件上，如图所示： 
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建议用户在选择显示 boundary line 的同时关闭三角形 mesh 的显示（mesh on

按钮 off），这样就能更清楚地观察 boundary line 的分布，不会因为线条太多

而难以分辨。 

在缺省情况下，材料边界线用灰色来显示，用户可以在 property->boundary 

line->boundary line color 中修改 boundary line 的颜色，例如我们把它改成

黑色： 
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用黑色线条会让材料边界线看起来更明显。 

用户可能会觉得位于三维器件中间的那些 xy plane 的材料边界线太多太乱，不

如不要显示，那么我们可以选择 property->boundary line->show z-plane 

boundary，把该复选框取消选中就可以隐藏中间的那些 xy plane 的边界线，

让画面看起来更干净整洁： 
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用户还可以通过 property->boundary line->Boundary Line Thickness 来调

整 material boundary line 的线宽。 

5）Mesh Line 

Property->Mesh Line 属性页用来调整三角形网格边界线的一些绘制属性： 
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在缺省情况下，系统会根据三角形的颜色来自动设置三角形边界线的颜色（mesh 

color type=System Color）,如下图所示： 
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如果用户想要自己设置三角形网格线的颜色，可以选择 property->Mesh 

Line->Self-defined Color，并在下面的 Mesh Line Color 颜色框中选择想要的

颜色。例如我们把上面例子的 mesh line color 改成蓝色： 

 

 

 

得到的结果如下： 
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“Show Mesh Line for Hidden Materials” 复选框用来显示被隐藏材料的

mesh line。如上图中显示的三维器件，假如我们隐藏中间的三种材料，得到的

显示结果如下： 
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隐藏材料的同时属于这部分材料的 mesh line 也被隐藏起来了，假如我们想单独

查看属于这些被隐藏材料的 mesh line，就可以选中“Show Mesh Line for 

Hidden Materials” 复选框，那么这部分被隐藏的 Mesh line 也会被显示出来： 

 

 

“Display Node”复选框用来显示 mesh line 上的 node 节点，如下图所示： 
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“mesh Line Thickness”用来调整 mesh line 的线宽。 

1.1.1.11 界面介绍>界面布局>常用工具栏按钮>2D Z Planes View 

2d Z Planes View 按钮用于选择三维器件上的 xy 原始面进行查看，如下图所示

的三维器件由 25 个 xy 面组成： 
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用户可以通过在工具栏按钮面板中的 2D Z Planes View 下拉框中选择其中任意

一个原始 xy 二维面进行查看： 

 

 

当用户点击 2d zplane view 按钮时，系统显示 z 方向上第一个二维面的结构图，

用户也可以在旁边的下拉框列表里选择任意一个 z plane 进行查看，如下图显示

的是第 25 个 xy plane： 
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1.1.1.12 界面介绍>界面布局>常用工具栏按钮>Zoom In & Zoom Out 

Zoom In 和 Zoom Out 两个按钮用来放大或缩小当前屏幕显

示的图像。每按一下按钮，图形会按照当前大小的 75%进行缩放。如果用户想

用自由度更高的缩放方式，可以选择菜单项 Option->Operation->Zoom 

View，用鼠标在屏幕上拖动的方式进行缩放。 

1.1.1.13 界面介绍>界面布局>常用工具栏按钮>Region 

 

上面提到的 Zoom In 和 Zoom Out 按钮是用来对物体进行整体的放大和缩小，

有时候用户想要选择物体的某个局部范围进行放大，这时候可以使用工具栏里面
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的 region 按钮进行局部缩放。例如下面显示的这个三维例子： 

 

 

如果想要查看 Y 方向上 0-0.5 的范围内的结构，可以点击 region 按钮在对话框

中输入 Y 的范围从 0 到 0.5： 
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点击”ok”按钮后就会显示 Y 方向上从 0-0.5 范围内的放大区域图： 
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同样对于二维器件用户也可以指定在 x 和 y 方向上的范围进行细节放大。如下图

所示的二维器件： 

 

如果用户想要查看 y<0 范围内的细节图，可以点击“region”按钮，这时鼠标

变成十字光标，用户可以按下鼠标在屏幕上需要放大的区域进行拖动选取范围，

如下图所示： 
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可以进行多次选取放大，直到得到满意的显示区域，如下图所示： 

 

 

除了用鼠标拖动选取放大范围，用户也可以在窗口上方的坐标输入框内输入 x
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和 y 的范围来得到更精确的显示区域： 

 

输入完成后只要按钮右边的蓝色箭头按钮就可以得到相应范围内的三角形

contour 显示。 

1.1.1.14 界面介绍>界面布局>常用工具栏按钮>Undo 

 

Undo 按钮用来取消上一步进行的操作，包括取消旋转、移动、放大等操作。 

1.1.1.15 界面介绍>界面布局>常用工具栏按钮>Ruler 

 

该功能按钮用来在 2d contour fill 上用鼠标拖动的方式量取两点之间的距离。

当选中”ruler”按钮后，先在任意一点（起点）按下鼠标，然后拖动鼠标至终

点位置，这时屏幕上会显示起始点和终止点的坐标以及两点之间的距离，如下图

所示： 
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1.1.1.16 界面介绍>界面布局>常用工具栏按钮>Rotate 

 

功能：旋转三维物体。 

当该按钮为选中状态时，光标变为手形，用户可以在屏幕上用鼠标拖动的方式来

对物体进行旋转。该按钮与菜单项 option->operation->Drag for 3d rotation

的功能相同，都是对物体进行任意方向上的旋转，用户也可以选择菜单项

tools->set display property->set rotate degree 来设置固定的旋转角度。具

体功能操作会在下面的菜单项功能里进行详细说明。 

1.1.1.17 界面介绍>界面布局>常用工具栏按钮>Move 
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和 rotate 按钮功能类似，move 按钮用来对物体进行平移，选中按钮后只要按

下鼠标在屏幕上进行拖动，就可以将物体移动到屏幕的任意位置。该按钮与菜单

项 option->operation->Mouse Move 的功能相同。 

1.1.1.18 界面介绍>界面布局>常用工具栏按钮>Overlay 

 

该功能可将多个窗口的图形显示到同一窗口上进行数据比较，具体用法可参见 

菜单项说明->View Data-> Combined Plots. 

1.1.1.19 界面介绍>界面布局>常用工具栏按钮>Z-Connect 
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1）Internal Connection 

  Crosslightview 在绘制三维物体时，在原始的 xy 面的基础上，还要绘

制 Z 方向上的三角形，这些三角形数据可以通过多种方法来获得，缺省的连接

方 法 是 使 用 内 部 提 供 的 filling volume 数 据 ， 也 就 是 所 谓 的 “ Internal 

Connection”（见上图对话框中的第一个连接选项），如下图中的例子在 Z 方向

上使用的就是 filling volume 数据： 
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  Filling volume 是系统内部根据原始的 xy 面的数据进行插值计算获得，

因此数值相对其他几种连接方法更为精确，但是一些老版本的产品中没有 filling 

volume 数 据 ， 因 为 无 法 使 用 “ internal connection ” 选 项 来 绘 制 。

Crosslightview 会自动判断当前例子有没有 filling volume 数据，如果没有就

将该选项置灰。 

 

2）Color Box 

  在 filling volume 数据产生以前，crosslightview 使用 color box 方法

来连接 Z 方向上的各个 xy 面。所谓的 color box 方法就是将相邻的两个 xy 平

面延伸到两个面中间的位置，从而形成两个相互连接的色块，如下图所示： 
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该方法的优点是完全复制了原始面的数据，所以在颜色值上不会发生计算错误。

缺点是在不同的 xy 面之间没有进行插值计算，因此连接部分会产生阶梯状的突

起，显得不够平滑。假如我们将上面那个例子以 color box 的方法进行连接，

绘制的效果如下图所示： 
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3）Taper Box 

  Taper Box 连接方法能够产生和 internal connection 相类似的仿真效

果，前提是例子内部已经产生 taper 连接所需要的数据，这一点 crosslightview

可以自动做出相应的判断。以下是用 taper box 连接方法所生成的效果： 

 

 

可以看到显示的结果比 color box 方法平滑很多。 

 

4）Smooth between Planes 

该选项用来设置相邻 xy 面之间的参数值插值率（材料值除外），使面与面之间的

颜色过渡更自然。以上述的例子为例，假如我们用 color box 连接方法绘制参数

conduction band 得到的效果如下： 
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  可以看到面与面之间的参数值并没有进行插值计算，颜色过渡不自然，

如果改成“smooth between planes”选项，则会有一个比较明显的颜色过渡

变化体现在不同的 xy 面的连接部分： 

 

5）其余三种连接方法：Use Box Line、Material Boundary Connection 和

Old Insert Mesh Connection 是比较老的版本中提供的连接方法，现在已不常
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用，用户可以根据需要尝试这些方法来调整显示效果。 

 

6）Color Smooth Ratio 

  Color Smooth Ratio 用来调整相邻两个 xy 面之间的颜色插值率，除了

material number 以外的其他变量均可使用。尤其是当使用 color box 方法来

连接 xy 面时，会出现上面提到过的颜色阶梯过渡不自然的现象，这时可以调整

color smooth ratio 来 使 相 邻 两 个 面 之 间 的 颜 色 平 缓 过 渡 。 如 上 述 的

conduction band 使用 color box 进行连接的三维图，假如我们将 color 

smooth ratio 设为 0.5，会得到以下的显示结果： 
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7）除了设置 Z 方向上连接方法以外，还有两个复选框“no connection”和“only 

connection”可以用来设置是否显示 Z 方向连接部分还是只显示原始的 xy 面。 

假如选中“no connection”选项，系统只显示原始的 xy 面，不会显示 Z 方向

上连接的部分，如下图所示： 

 

 

  相反地如果选中“only connection”复选框，那么只显示 Z 方向上连

接的部分，不显示 xy 方向上的原始面： 
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1.1.1.20 界面介绍>界面布局>常用工具栏按钮>Log 

 

该工具栏按钮可以用来对当前的结果值取 Log 或 Linear 操作。分为以下两种情

况： 

1）对于一维的数据曲线（如 I-V 曲线），可以分别对 x 或 y 坐标值进行取 log

操作。如下图所示的 scan bias 曲线： 
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如果我们想要对X坐标取log，在Select Log() Option对话框中选择Horizontal 

Axis Scale，点 OK 按钮 : 

 

 

然后弹出以下对话框，要求用户选择运算类型（包括 log10，20log10，Original 

Scale 等多种结果类型） 
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如果我们对上述 scan bias 曲线的横坐标取 log10()运算，则得到以下的结果： 

 

 

2）对于二维或三维的参数分布（contour fill），我们可以对该参数变量的值取

log，如下图所示的 3d contour cube： 
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如果对 field_x 取 log10，在 Select Log() Option 对话框中选择“Structure Data 

Scale”选项： 

 

 

 

 

得到的结果显示如下： 
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1.1.1.21 界面介绍>界面布局>常用工具栏按钮>Set Color Range  

 

对于下图所示的 field_x 三维分布图，我们可以看到虽然变量值范围在 0 - 

0.00015 之间，但大部分值分布范围集中在 0 - 2e-005 区间内： 
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假如用户想要对该 0 – 2e-005 范围内的颜色值进行细分，可以在工具栏面板的

set range 输入框内输入该值分布的范围区间: 0 – 2e-005 , 然后点击旁边的

range 按钮，系统会对该输入范围的值进行重新计算分配颜色： 

 

系统会根据用户所设置的范围重新计算颜色分布，结果如下，可以看到通过重新

设置颜色值得范围我们可以更清楚地观察整个器件在该变量参数上的值的分布： 
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如果想要回到缺省的颜色范围只需要点击 Range Reset 按钮就可以了。 

1.1.1.22 界面介绍>界面布局>常用工具栏按钮>Scan Bias 

 

绘制 scan bias 曲线的快捷方式按钮，具体操作方法请见 菜单项说明->View 

Data Menu->Scan Bias Data. 

 

1.1.1.23 界面介绍>界面布局>常用工具栏按钮>Band 

 

绘制 Band Diagram 的快捷方式按钮，具体操作方法请见 菜单项说明->View 

Data Menu->Band Diagram. 



 

 

第 85 页 共 238 页 

第 85 页 共 238 页 

1.1.1.24 界面介绍>界面布局>常用工具栏按钮>Contour 

 

用来在二维或三维的 contour fill 上显示 contour line 等高线，和菜单项->view 

data menu->contour line 的功能相同。 

1.1.1.25 界面介绍>界面布局>常用工具栏按钮>Surface 

 

以三维的方式显示 2d contour fill，用来显示 xy 平面上的变量值的分布曲线，z

坐标代表了变量值。功能同菜单项->view data menu->3d Surface Fill 

1.1.1.26 界面介绍>界面布局>常用工具栏按钮>VT Extract 

 

该工具栏按钮用来提取一些曲线的 VT 值（阈值）。如下图所示横坐标为

voltage_i，纵坐标为 current_i 的 scan bias 曲线，如下图所示： 
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红色曲线为 scan bias 曲线，紫色为斜率曲线，同时标注了斜率最大值 GM，橘

色为斜率切线，斜率切线和 scan bias 曲线的交点标注为 VTH。 

1.1.2 界面介绍>界面布局>材料列表 

1.1.2.1 界面介绍>界面布局>材料列表>材料信息 

在屏幕左下方的材料列表里列出了当前器件的所有材料名称和相关信息： 

 

每一条材料信息里包含了五项内容： 
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1）材料编号（index ） 

通常从 1 开始连续编号，从 1 – n 种材料。 

2）材料名称（Material Name） 

crosslightview 是从.std 或.str 文件里获得材料名称，材料名称里包含相应的参

数值，如上图所示。 

3）材料颜色（color） 

每一种材料被系统自动分配一种颜色，用户可以通过双击材料列表里的颜色来修

改当前材料的颜色，如上述材料中的 ingan(x=0)，假如在对话框中将浅蓝色改

为橘色： 

 

 

修改前后对比图如下： 
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4）材料类型（type） 

每一种材料的类型是根据 crosslight.mac 里定义的类型获得的，不能修改。 

 

5）材料透明度（Transparency） 

在缺省情况下，材料以不透明的方式显示在屏幕上，如果用户想要以半透明的方

式观察材料，可以选中每一种材料 Transparency 一栏中的复选框 ，例如

对于上面的例子，我们选择对于材料 1 和材料 5 进行半透明处理，用缺省的透

明度值=0.4： 

 

 

处理后显示效果如下： 
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用户也可以对透明度进行调节，有两种方法： 

方法 1） 在需要调整的材料项的 transparency 一栏点击右键，点击”change 

transparency ratio…”按钮，在对话框中输入想要设置的透明度（在 0.0-1.0

范围内），例如我们把透明度设为 0.1： 
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则材料的透明度会增加，如下图所示： 

 

 

方法 2） 点击菜单项 Tools->Set Display Property->Set Transparency Ratio，

在对话框中输入材料的透明度值（0-1.0 之间），得到的效果和方法 1 是一样的。 
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1.1.2.2 界面介绍>界面布局>材料列表>隐藏和显示每一种材料 

每一条材料列表项前面都有一个复选框，缺省情况下为选中状态，表示该材料目

前为显示状态： 

 

如果想要隐藏某种材料，只要把该材料前的复选框取消选中就可以了。例如我们

把上例中的材料 1 和材料 5 进行隐藏，得到的结果如下： 
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1.1.3 界面介绍>界面布局>变量参数列表 

在屏幕的右方有一个参数变量列表，里面列出了当前显示器件的所有变量名称，

如下图所示： 
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一些主要或常用的变量被放在“Primary”一栏里，而其他一些不太常用的变量

放在“Secondary”一栏里。用户可以点击其中任意一个变量查看它的分布，
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也可以在最上方的输入框中输入变量名称的关键字进行搜索快速定位到所需要

的变量，如下图所示： 

 

通过输入“curr”来缩小查找范围，列出所有包含“curr”的变量名称。 

1.2 界面介绍>菜单项说明 

1.2.1 界面介绍>菜单项说明>File Menu 

1.2.1.1 界面介绍>菜单项说明>File Menu>File Open 

1）Process Directory 

使用菜单项 File->File Open ->Process Directory 可以打开任意路径下的输
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出文件，该模式可以打开多种格式的输出文件（比如.std,.str,.pro.dat.sho 等格

式） 

 

 

 

 

 

2）Device Directory 

使用菜单项 File->File Open->Device Directory 打开某一项目文件夹下的 std

文件，该模式只能用于打开格式为 std 的输出文件。 



 

 

第 96 页 共 238 页 

第 96 页 共 238 页 

                                          

 

 

 

选择 std 文件所在的项目文件夹，点击确定按钮： 
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在该项目文件夹下的所有 std 文件列表中选择一个 std 文件进行查看： 

 

 

在上述 std 文件列表中选择任意一个 std 文件进行显示。 

                                              

1.2.1.2 界面介绍>菜单项说明>File Menu>Quick Structure View 

使用菜单项 File->File Open->Quick Structure View 可以快速查看原始 xy 面
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的结构和材料信息，不包含 Z 方向上的连接 

 

1.2.1.3 界面介绍>菜单项说明>File Menu>FDTD View 

FDTD View 用来读取.sol 文件中和 FDTD 相关的一些模块并显示在屏幕上，当

用户选择菜单项 File Open->FDTD View 以后，在弹出的选择文件对话框中选

择一个.sol 文件，如下图所示： 
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系统会读取该.sol 文件里的 fdtd_model，fdtd_source 和 fdtd_define_region

等模块，将数据进行提取分析后在屏幕上显示 FDTD 相关的一些结构，如 PML，

Source, Region 等, 如下图所示： 
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以下显示的是 FDTD 区域的 PML 定义和.sol 文件中的 fdtd_model 模块的对应

关系： 
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在缺省情况下，FDTD 打开后采用多个视角同时显示的方式，包括 xyz，xy，xz，

yz 四个方向上的显示视图，如下图所示： 

.
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用户也可以通过菜单项 Tools->FDTD Control Parameters 来调整 FDTD 相关

的一些参数，具体方法详见菜单项说明->Tools->FDTD Control Parameters. 

1.2.1.4 界面介绍>菜单项说明>File Menu>File Save 

使用菜单项 File->Save File 将当前绘制的图形保存为图片格式或者文本格式

的文件，文本文件中包含当前绘图的点坐标和材料信息等数据。 

先在如下所示的 File save option 对话框选择想要保存的文件格式（图片或文

本） 
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1）保存图片格式 

如果选择”Save as image File”, 接下来会弹出对话框要求用户选择仅保存当

前图片或是同时保存多个窗口的图片： 

 

 

对于仅保存当前单个窗口的选项，系统会要求用户输入图片文件名并保存，如果

选择多个窗口同时保存，则用户在对话框中选择需要保存的窗口名称（可以多选）

并点击”ok”，系统会自动保存这些窗口到图片文件中并以该窗口的标题名称作

为图片文件的名称（见”Select Multiple plots to Export” 对话框）。目前系
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统能保存的图片格式为 jpg 或 bmp 格式. 

 

        Select multiple windows to save as picture 
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                   Save multiple windows to pictures 

 

2）保存为文本格式 （dat 或 txt 文件） 

文本文件里记录了三角形或者线段的点坐标信息以及变量和材料值等信息。Txt

和 dat 格式的区别在于：txt 里面包含了对于数据段的文字说明信息，比如：plane 

number, triangle num, line num 等， 而 dat 格式的文件里仅保存坐标、变

量等数值，没有相关说明文字。如下图所示： 
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1.2.1.5 界面介绍>菜单项说明>File Menu>Close File 

选择菜单项 File->Close File 用于关闭当前窗口。 

 

1.2.1.6 界面介绍>菜单项说明>File Menu>Export 

菜单项 File->Export 用来输出用户指定格式的数据，共有以下四种选项： 
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                File Export Dialog Box 

 

1）Export Raw Data 

用来输出原始面的 node 值，保存到当前路径下的 rawdata.txt 文件中，格式如

下： 

 

variable name 

 net_doping 

 plane number 

 1 

 number of nodes of this plane 

 236 
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 doping    node_number    material_number  (listing of all nodes) 

 

2）Export Uniform Data 

用来输出指定 xyz 范围内的 cut 网格数据，用户需要在对话框中输入 x,y 和 z 方

向 上 cut 的 范 围 和 网 格 数 ， 得 到 的 网 格 数 据 被 保 存 到 当 前 路 径 下 的

uniformdata.txt 文件中。 

 

 

 

3）Export Filling Volume data 

对于有 Filling Volume 数据的三维结构，使用该选项可以输出 Filling Volume

的数据信息。包括 volume 的数量，每个 volume 的顶点数，每个顶点的坐标和

材料信息等(x,y,z,material number)。格式如下： 
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输出 filling volume data 的时候有一个选项“export vertex number”,用于在

每一个 filling volume 顶点坐标的后面输出该顶点在所有 filling volume 中的

共用数(x,y,z,material number, vertex num)，注意该选项有可能会花比较长的

时间来搜索共用顶点。 

 

 

4）Export Plane Triangle Data 

用来输出原始面和三角形信息，格式如下： 
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三角形坐标数据为 x, y, z, node number 和 material number 

 

5）Export 1d-cut line data 

该选项用于输出在二维 contour 面上进行 cut 后的数据线 1d cut line 的坐标，

比如下图中的 cut 数据线： 
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输出后的数据将被保存到当前路径下的 1dcut_data.txt 文件中： 

 

1.2.1.7 界面介绍>菜单项说明>File Menu>Print 

菜单项 File->Print 用来打印当前屏幕内容。 
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1.2.1.8 界面介绍>菜单项说明>File Menu>Print Preview 

菜单项 File->Print Preview 用来在打印前预览打印内容。 

                                          

1.2.1.9 界面介绍>菜单项说明>File Menu>Print Setup 

菜单项 File->Print Setup 用来设置打印机选项。. 
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.  

1.2.2 界面介绍>菜单项说明>View Data Menu 

1.2.2.1 界面介绍>菜单项说明>View Data Menu>Structural Data 

1）3D Cubic Contour 

查看三维结构的材料或变量值分布，该菜单项仅适用于具有多个面的三维结构，

用户可以选择窗口右侧的变量列表在不同变量的三维结构中切换。 
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                 3d cubic contour – Material Number 

 

 

                  3d cubic contour – Net Doping 

2）Contour Line 

在当前的二维或三维结构（2d contour / 3d cubic contour）上显示等高线。

该功能仅在显示 2d contour fill 或者 cubic contour 的时候有效。 
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                2d contour line 

 

 

                             3d contour line 

3）2d Contour Fill 

用来显示当前 xy plane 的二维面的结构，用户可以选择原始的网格面，也可以

在原始面之间选择一个 Z 值插值面的数据进行显示。（详见常用工具栏按钮->2D 

Z Planes View）。 
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4）3d Surface Fill 

以三维的方式显示 2d contour fill，用来显示当前 xy 平面上的变量值的分布网

格结构，z 坐标代表了变量值： 

 

5）3d Surface Grid 

当视图切换到 3d Surface Fill 时，surface 上的网格线缺省是处于显示状态，此

时 3d Surface Grid 菜单项为选中(check)状态。 
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如果取消选中(uncheck)该选项，3d surface 上的网格线不再被显示(如下图)： 

 

6）Single Contour Line 

显示某个固定参数值的 contour 等高线。如下图，用户选择查看参数 potential
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值为-1.68 的 contour line： 

 

 

 

经过计算后得到的结果如下： 

 

    7）ISO Surface 

用于显示固定参数值的三维 surface 网格面，用户在对话框中输入参数值（不得
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超出合法值范围），通过计算得到符合该参数值的网格范围（该功能仅适用于具

有 filling volume 的三维结构）. 

 

                    输入参数值 

 

              得到符合该参数值的 Iso surface 
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1.2.2.2 界面介绍>菜单项说明>View Data Menu>Scan Bias Data  

Scan bias 曲线的绘制仅适用于输出文件格式为.std 的例子。 

1）绘制 scan bias 曲线 

用户先在 scan bias 对话框中选择分别代表纵向(vertical axis)和横向坐标

(horizontal axis)scan bias 变量，如下图： 

横向坐标为 Current，纵向坐标为 Voltage 
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然后选择需要显示的 scan number，每一个 std 文件代表不同的 scan number，

在这个例子中，std_0001 的 scan number 为 0，std_0002 的 scan number

为 1，其余的 std 文件的 scan number 为 2，我们选择 scan number=1 和 2

的 scan bias 数据进行显示，显示结果如下： 

 

不同 scan number 的 sca bias 曲线用不同的颜色来显示。 

同时用户可以在 scan bias 对话框中设置横坐标和纵坐标的 contact number

以及 scale，mode index 等参数来调整显示结果。 

2）设置 scan bias 曲线 

在绘制 scan bias 曲线的基础上，用户也可以设置 scan bias 曲线的绘制方式，

如显示 nurbs 样条曲线、L-I 曲线等，具体设置方法请参见菜单项说明->Tools 

Menu->Set Relation Plot。 
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1.2.2.3 界面介绍>菜单项说明>View Data Menu>Batch Scan Bias 

Batch Scan Bias 在 scan bias 的基础上增加了两个功能： 

设置多个纵坐标变量，同时显示多条 scan bias 曲线。如下图中，横向坐标变量

仍为 voltage，用户选择的纵向坐标变量有两个：curret 和 volt_res，不同的参

数用不同的颜色加以区分，红色代表 current，绿色代表 volt_res： 

 

                设置多个纵向坐标变量 
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用不同的颜色曲线区分不同的纵坐标参数变量 

 

Extract FET Threshold Voltage 

该选项直接设定 x 方向的参数变量为 voltage，y 方向的参数变量为 current，

然后绘制相应的 scan bias 曲线。用户可以点击“set horizontal axis”列表框

下方的” Extract FET Threshold Voltage”按钮，在弹出的参数对话框中设置

voltage_i 和 current_i 中的 i 值，缺省为 1。 
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然后系统自动计算出按照 scan number 从小到大排列的 scan bias 曲线，如下

图所示： 

 

1.2.2.4 界面介绍>菜单项说明>View Data Menu>Spectrum Data 

画 spectrum data 曲线时先在对话框左边一栏用来选择需要显示的 std 文件，

如果不选则默认为全部显示，右边的列表中选择需要显示的 spectrum 变量，然
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后点击 ok 按钮，系统会计算出每个 std 文件相应的 spectrum data 绘制成曲线

显示在屏幕上： 
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1.2.2.5 界面介绍>菜单项说明>View Data Menu>LED Special Data 

该菜单项的操作方式与 Spectrum Data 类似，先在对话框左侧列表中选择需要

显示的文件（可多选），然后在右侧列表中选择变量： 

 

 

得到的结果如下： 
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1.2.2.6 界面介绍>菜单项说明>View Data Menu>Vector Plot 

Vector Plot 用于在 2d contour fill 上画矢量分布图，仅适用于 std 文件以及矢

量类型的参数变量如 current_x,current_y,field_x,field_y 等等，下图所示为某个

器件的 current_x 的矢量分布图。 
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在缺省情况下 crosslightview 显示矢量相对长度大于 0.1 的矢量数据，用户也

可以自己调整相对矢量长度，如下图所示的是相对矢量长度为缺省值 0.1 的

current_x 分布： 
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如果用户想要显示更多的矢量线，可以把相对矢量长度调整为 0.05，也就是说

只要相对长度大于 0.05 的都会被显示。方法是点击菜单项 Tools->Set Display 

Property->Set Relative Vector Size，在对话框中输入 Relative Vector Size = 

0.05 ： 

 

于是可以看到显示的矢量分布图更密、箭头线段更多了： 

 

 

我们可以进一步设置 Relative Vector Size = 0.01，来显示更多的矢量线段： 
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1.2.2.7 界面介绍>菜单项说明>View Data Menu>Material Boundary 

Plot 

当该菜单项为选中状态(check)时，2d 或 3d contour fill 上的材料边界线被显

示，否则不显示材料边界。 
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选中 Material Boundary Plot 菜单项时显示材料边界 

 

取消选中(uncheck) Material Boundary Plot 菜单项时不显示材料边界 

1.2.2.8 界面介绍>菜单项说明>View Data Menu>Mesh Plot 

当该菜单项为选中状态(check)时，2d 或 3d contour fill 上的三角形网格边界

线被显示，否则不显示网格线。 
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选中 Mesh Plot 菜单项时显示网格线 

 

                      取消选中(uncheck) Mesh Plot 菜单项时不显示网格

线 
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1.2.2.9 界面介绍>菜单项说明>View Data Menu>Electrode Plot 

该菜单项用于显示（或不显示）电极区域（仅适用于 std 文件），如下图所示： 

 

                  显示电极（Electrode）区域  

1.2.2.10 界面介绍>菜单项说明>View Data Menu>Flow Line 

该菜单项用于显示 Total Current Flow Line（仅用于 std 文件）,如下图所示： 
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                         Total Current Flow Line（line num=20） 

 

用户可以通过选择菜单项 Flow Line Property 来调整绘制 Flow Line 的一些相

关属性： 
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缺省的绘制线条的数目为 20，如果将 line num 调整为 40，则显示的线条数目

增加到 40 条，如下图所示： 
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             Total Current Flow Line（line num=40） 

 

如果进一步调整 Mesh Num，比如设置 X Mesh Num=40,Y Mesh Num=40

（缺省为 20），可以在更密的网格基础上计算 flow line，体现更多的细节，如

下图所示： 

 

Total Current Flow Line（mesh num=40） 

用户也可以选择某个 mesh 范围来显示该区域内的 flow line，如下图中在对话

框中设定 x 范围 2-4，Y 范围 1.5-2，系统会重新计算出该范围内的 flow line data

并进行显示： 
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                 重新设置 draw range 

 

                X from 2 to 4，Y from 1.5 to 2 范围内的 flow line  
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1.2.2.11 界面介绍>菜单项说明>View Data Menu>Combined Plots 

            该功能用于将同一类型的多条曲线绘制在同一窗口中，以便用户

对数据进行比较。可以绘制的曲线类型包括 scan bias lines,1d cut lines, 2d 

contour fill, spectrum data lines, LED data lines, suprem lines, z-cut lines

等。当用户点击该菜单项后会出现如下对话框，用于选择需要绘制的曲线类型： 

 

 

 当用户点击左边列表中的绘制类型后（比如 2d contour fill plots）,右边列

表中将出现目前处于显示状态的该类型下的所有窗口列表，如上图所示，共有三

个 2d contour fill 类型的窗口，用户可以在其中选择任意两个进行重叠显示。

比如我们选择将变量名为 potential 和 cond_band 的两个 2d contour fill 显示

在同一窗口中，显示结果如下： 
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 用户可以选择窗口左侧工具栏中的 move 按钮来移动上面一层的图形，从而

进行数据对比。 

  

 例 2：比如目前系统中有两条 1d cut 曲线，分别显示如下： 
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当我们选择 combined plots->1d cut plots 进行叠加显示后，出现的结果如下，

两条曲线被分别用不同的颜色显示在同一个画面中： 

 

1.2.2.12 界面介绍>菜单项说明>View Data Menu>Band Diagram 

用于绘制 band 类型的参数值的分布曲线，如 conduction band，Valence band

等，仅适用于 std 文件。 

1）2D 器件： 

仅在 xy 平面上绘制 band diagram，需要用户在 2d contour fill 上指定一条

1d-cut 曲线，系统计算出该 cut 曲线上的 band diagram 数据并显示。当用户

点击菜单项 view->band diagram 后，屏幕显示如下提示框提醒用户输入起点

和终点位置来指定一条 1d-cut 曲线： 
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用户有两种方式指定 1d-cut line，一种方式是直接在屏幕上通过鼠标拖动生成

一条 cut 线，如下图所示： 

 

 

另一种方式是在标签页上方的输入框内输入 cut 线的起点和终点坐标，该方式的

好处是能够精确地指定 cut 的范围，如下图所示： 

 

然后点击输入框右方的蓝色箭头按钮，系统会根据 cut line 的范围来计算 band 

diagram 的数据并将曲线绘制在屏幕上，如下图所示： 
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共有三种类型的 band，E_c 代表 conduction band 和 Valence band，E_f 代

表 Electron IMREF 和 Hole IMREF，E_v 代表 LH Valence Band，当输出文件

中包含 wave points 数据时 wave points 也会被显示，如上图中的 Valence 

band wave points 和 Conduction band wave points. 

 

2）3D 器件： 

   有两种显示方式，一种是在 xy 平面上的 band diagram 分布，另一种是在 z

方向上的 band diagram 分布。当用户点击 band diagram 菜单项后，屏幕上

会显示如下对话框要求用户选择绘制 xy 或是 z 方向上的曲线，缺省显示方式为

xy 面上的 band diagram 曲线： 
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如果用户选择显示 xy 面上的 band diagram 分布，操作方式同上 1）中的二维

显示方式，如果选择显示 z 方向上的 band diagram 分布，需要用户在以下对

话框中输入 xy 坐标以及 z 方向上的起点和终点坐标： 

 

                 

 

系统会计算出 z 方向上的 band diagram 分布并显示在屏幕上，如图所示： 
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1.2.2.13 界面介绍>菜单项说明>View Data Menu>1D Cut in Z Direction 

用于在 Z 方向上进行 1D Cut，仅用于三维器件，如下图所示的三维器件: 
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在对话框中输入 xy 坐标以及 z 方向上的起点和终点坐标： 

 

 

 

系统计算出位于 x=150,y=150， z 范围从 3 到 3.3638 的 1d cut 曲线并显示

在屏幕上： 
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                    Z 方向上的 1d-cut 曲线 

1.2.2.14 界面介绍>菜单项说明>View Data Menu>Draw YZ/XZ Plane 

区别于菜单项 view->Structural Data->2d contour fill 仅显示 xy 方向上的 2d 

contour fill, 该菜单项用于显示三维器件在 yz 或 xz 方向上的某个指定面的 2d 

contour fill。 

首先在对话框中选择需要显示的二维面的方向，缺省是显示 xy 方向上的原始二

维面，用户可以选择 xz 面，然后输入某个特定的 Y 值，或者 yz 面，输入固定 X

值进行显示，如下图所示： 
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以下是一个三维器件的材料分布以及 x=150 处的 yz 二维面的分布： 

 

                3d contour fill 
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                      YZ plane at x=150 

1.2.2.15 界面介绍>菜单项说明>View Data Menu>Net Doping 

计算 net doping 参数值的算法是： 

std 文件(APSYS/PICS3D/LASTIP)：N-type charge 变量为 Donor_conc，

P-type charge 变量为 Acceptor_conc. 

str 文 件 (SUPREM) ： N-type charge 变 量 包 括

Asa/Pa/Nitrogena/Sb/na_doping/na2_doping，P-type charge 变量包括

Ina/Ba/pa_doping/pa2_doping. 

计算公式为： 

zab = abs ( N-P ) 

If ( zab > 1.0E+5 )  

net_doping = signed ( log10 (zab) 
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   else   

    net_doping = signed ( log10 (1.0+zab) 

 

示例显示结果如下： 

 

1.2.2.16 界面介绍>菜单项说明>View Data Menu>Junction Line Plot 

该菜单项用来关闭或显示 net_doping 上的 Junction Line. 

Junction Line 是 net_doping=0 的 contour line，通常和 net_doping 的

contour fill 显示在一起，如下图所示: 
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如果取消选中菜单项 view->Junction Line Plot，则 Junction Line 不被显示。 

1.2.2.17 界面介绍>菜单项说明>View Data Menu>Depletion Edge 

Depletion edge 的算法是：假设有两个变量 var1 和 var2 

var1 = abs[ electron(node) / (n-doping - p-doping) ] 

var2 = abs[ hole(node) / (n-doping - p-dopoing) ] 

n-doping = donor_conc   p-doping = acceptor_conc 

分别计算出 var1=0.1 和 var2=0.1 的 contour line ，这两条 contour line

之间包围的区域被称作 Depletion Region.  

通常在 net_doping 的基础上画出这两条 contour line， 被称为 depletion 

edge. 
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var1 和 var2 的缺省值为 0.1，用户可以通过 option->Set Depletion Fraction 

来调整这两个变量的值： 

 

1.2.2.18 界面介绍>菜单项说明>View Data Menu>Define Netdoping 

用户自定义 N-type 和 P-type 变量来得到想要的 net doping 结果（仅用于 str

文件）。 

如下图对话框中 var1-var3 为 N-type 变量，var4-var6 为 P-type 变量，用户

选择相应的参数名后，按照计算 net doping 的公式（参照 view->Net Doping

菜单项中的说明）来得到相应的结果。 
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1.2.2.19 界面介绍>菜单项说明>View Data Menu>Multiple variables 

1d-Cut 

把多个变量的 1D Cut Line 显示在同一个绘制图上。首先在对话框中选择想要

cut 的变量，如下图所示： 
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我们选择 valence band 和 wave intensity 两个变量同时进行 cut，然后在 2d 

contour fill 上用鼠标拖出 cut 线（或者在坐标输入框中输入 cut 起点和终点坐

标），得到的 cut 结果如下： 
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1.2.2.20 界面介绍>菜单项说明>View Data Menu>Y-Max Line 

先在 X 方向上设定一定数量的网格（如 x num=50），然后在 Y 方向上计算出每

一个 X 网格点的最大值并将这些最大值绘制出一条二维曲线，如下图显示的是

一个二维器件的 potential 分布： 
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当用户点击菜单项 view->Y-Max line，弹出对话框要求用户输入 x 方向上的网

格数，假设输入网格数为 50，系统计算出每一条 x line 上的 potential 最大值

并绘制出二维曲线： 
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1.2.2.21 界面介绍>菜单项说明>View Data Menu>NEGF Density 

先在对话框中输入两个参数（cond. subband valley index 和 cond. subband 

index）的值，缺省为 1，.然后系统计算出 NEGF density 的 contour 分布和曲

线并显示在屏幕上，如下图所示： 
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1.2.3 界面介绍>菜单项说明>Option Menu 

1.2.3.1 界面介绍>菜单项说明>Option Menu>Undo 

Undo 菜单项和工具栏面板里的 undo 按钮一样，用来取消上一步的旋转、放大、

移动等操作。 

1.2.3.2 界面介绍>菜单项说明>Option Menu>Operation 

1）Set Ruler Flag 

该菜单项与工具栏按钮 Ruler 的功能一样，用来打开或关闭距离标量尺，具体操

作请见常用工具栏按钮->Ruler 

2）Cut View 

该菜单项与工具栏按钮 1d Cut 的功能一样，用来在 2d contour fill 上进行 cut。

详见常用工具栏按钮->1D Cut. 
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3）Drag For 3D Rotation 

该菜单项与工具栏按钮 Rotate 的功能相同，都是对三维物体进行旋转，详见常

用工具栏按钮->Rotate. 

4）Mouse Move 

该菜单项与工具栏按钮 Move 的功能相同，使用鼠标拖动物体进行平移，详见

常用工具栏按钮->Move. 

5）Zoom View 

和上面提到的工具栏按钮中的 zoom in 和 zoom out 一样，该菜单项也是用来

放大和缩小屏幕上的物体的，区别在于 zoom in 和 zoom out 是每按一下进行

一次放大或缩小，如果选中了菜单项 zoom view，鼠标会变为手型，用户可以

任意在屏幕上拖动鼠标来进行放大和缩小，比 zoom in 和 zoom out 更灵活方

便。 

6）Reset View 

当用户对物体进行放大、旋转、移动等操作后，如果想回到最初的状态，可以点

击 Option->Operation->Reset View 菜单项，相当于 Undo 前面所有的操作

步骤。 

1.2.3.3 界面介绍>菜单项说明>Option Menu>Select Region 

该菜单项的功能和工具栏按钮 Region 一样，用来选择器件的某个局部范围进行

查看。具体操作请见常用工具栏按钮->Region. 
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1.2.3.4 界面介绍>菜单项说明>Option Menu>Perspective View & 

Parallel View 

Crosslightview 对于三维物体的显示有两种投影方式：透视投影（Perspective 

View）和平行投影（Parallel View），缺省使用的是透视投影法，比平行投影法

更能反映物体的真实三维效果。用户可以通过点击这两个菜单项在两种投影方式

之间进行切换。以下为两种投影法之间的对比图：（左边为 Perspective View，

右边为 Parallel View） 

 

 

对于透视投影我们也可以设置视点和物体之间的距离以及透视投影的角度，方法

是点击菜单项 tools->Set Display Property->Set View Point/Angle，弹出以

下对话框： 
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第一个输入框用来设置视点和物体之间的距离，缺省为 10，第二个输入框用来

设置透视投影的角度，缺省为 8。以下显示了透视角度分别为 8，30 和 70 的效

果： 

 

 

 

透视角度越小越接近于平行投影。 

1.2.3.5 界面介绍>菜单项说明>Option Menu>Flip X-Axis / Flip Y-Axis 

该菜单项与工具栏按钮 Property->Axis Property 中的 Flip Axis 功能相同，用

来反转 X 和 Y 坐标。详见工具栏按钮 Property->Axis Property. 



 

 

第 162 页 共 238 页 

第 162 页 共 238 页 

1.2.3.6 界面介绍>菜单项说明>Option Menu>Set CSuprem Material 

对于 Suprem 器件来说，所有的材料信息都被保存在 suprem_mater.txt 文件中，

包括材料编号和名称等，如下图所示： 

 

 

 

用户可以通过 Crosslightview 里的 Option->Set CSuprem Material 菜单项来

设置材料信息。如下图所示的器件一共有五种材料： 
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我们点击该菜单项后出现以下对话框，其中列出了 suprem 的所有材料列表： 
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如果我们想把材料 Si 名称修改为 Si – Main Material，可以在列表中选中 Si,

点击 Edit 按钮，在对话框中输入新的材料名称： 
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然后点击 OK 按钮，可以看到屏幕左侧的 material list 和右边的 color bar 中的

相应材料名称被修改成新的材料名称 Si-New Material： 
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1.2.3.7 界面介绍>菜单项说明>Option Menu>Set Material Show Flag 

该菜单项的功能类似于前面提到的在材料列表中设置每种材料的显示或隐藏状

态，在材料列表中我们是通过勾选每一项材料前面的复选框来打开或关闭当前材

料的显示，如果使用 option->Set Material Show Flag 菜单项，我们可以在对

话框中勾选相应材料的显示状态： 

 

 

例如针对前面示例中的三维器件，如果取消勾选 Si 材料，那么材料 Si 就不会被

显示，同时材料列表中的 Si 勾选状态也会被更新： 
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1.2.3.8 界面介绍>菜单项说明>Option Menu>Set Depletion Fraction 

用来设置 Depletion Edge 的缺省参数值，具体说明请参见菜单项说明->View 

Data Menu->Depletion Edge. 

1.2.3.9 界面介绍>菜单项说明>Option Menu>Set 3d Plane Connection 

Method 

该菜单项和工具栏按钮中的 Z-connect 功能相同，用来设置三维器件在 Z 方向

上的连接方式，具体说明请参见常用工具栏按钮->Z-Connect. 

1.2.3.10 界面介绍>菜单项说明>Option Menu>Set Bended Plane Type 

对于具有弯面（Bended Plane）的器件，用户可以选择查看原始弯面的 mesh，

也可以选择查看邻近的直面和与该弯面相结合的 mesh 数据。如下图所示的三维
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器件一共包含 31 个面： 
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其中直面用 plane index 来表示，弯面用 Bent index 来表示。当用户选择查看

某个弯面（如 Bent 10）时，系统会缺省显示第 10 个弯面的原始 mesh，如下

图所示： 

 

如果用户点击菜单项 Option->Set Bended Plane Type->Merge Type 选择查

看 Merge Type(弯面和相邻直面相结合的面)： 
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系统会通过其相邻的两个直面（Plane 6 和 Plane 11）重新计算得到合并后的

mesh 显示如下： 

 

 

1.2.3.11 界面介绍>菜单项说明>Option Menu>Set Mesh Type 

一些老版本的 Crosslightview 使用打印在输出文件中 Insert Mesh 来连接 Z 方

向上的 xy 面，因此用户除了查看原始 xy 面的三角形 Mesh 以外，可能还需要

查看 Z 方向上的 insert mesh，这时可以使用 option->Set Mesh Type 菜单项，

在 regular mesh 和 Insert Mesh 之间进行切换。该菜单项仅在 Set 3d Planes 

Connection Method 对话框中的“Old Insert Mesh Connection”选项激活

状态下才能使用，如下图所示： 
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以下显示的是一个具有 Insert Mesh 的三维结构在 Regular Mesh 和 Insert 

Mesh 之间切换的对比图： 
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                              Regular Mesh 
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                               Insert Mesh 

1.2.3.12 界面介绍>菜单项说明>Option Menu>Filling Volume Mode 

由于 Filling Volume 的数据量比较大，为了不影响显示速度，当用 Filling 

Volume Data 来连接 Z 方向上的二维面时，缺省情况下只用物体表面的 Filling 

Volume 数据（Exposed Surface）进行连接，但在有些情况下（比如用户想要

查看器件的内部结构时），我们必须使用器件内部完整的 Filling Volume 数据进

行显示，这时候就需要使用菜单项 Option->Filling Volume Mode，把 Exposed 

Surface 模式切换到 Total Filling Volume 模式。比如下面这个三维器件： 

 

 

当用户在材料列表中选择隐藏表面的 ingan 来查看内部的材料分布，系统会自

动切换到 total filling volume 模式，以显示内部的材料结构，如下图所示： 
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1.2.3.13 界面介绍>菜单项说明>Option Menu>Light On 

打开和关闭灯光效果。缺省情况下为了避免色差不使用灯光效果。以下显示的是

打开和关闭灯光的效果对比图： 
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1.2.3.14 界面介绍>菜单项说明>Option Menu>Set Light Position 

用户先可以通过菜单项 Option->Set Light Position 来调整光源位置。例如我

们把上图示例中的光源位置调整到 Z 轴的前半部： 

 

 

可以看到物体的前半部分被照亮了： 
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1.2.3.15 界面介绍>菜单项说明>Option Menu>Show doping conc. in 

semiconductor materials only 

该菜单项仅用于 Suprem 的 net_doping，如果该菜单项处于选中状态，Nitride 

(SiN), Oxide (SiO2), Copper (Cu) 和 Aluminum 这四种材料的 Net Doping 

显示为 0。如下图所示的三维器件由 Si 和 SiO2 两种材料组成： 



 

 

第 177 页 共 238 页 

第 177 页 共 238 页 

 

当用户选择画 Net Doping 的时候，缺省情况下所有材料的 Net Doping 都被

计算并显示，如下图所示： 
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如果用户选中 Option->Show doping conc. in semiconductor materials 

only 菜单项，则上方的 SiO2 材料部分的 net doping 显示为 0，如下图所示： 
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1.2.3.16 界面介绍>菜单项说明>Option Menu>Show "Max ..." Label 

对 于 .std 文 件 ， 当 用 户 选 择 ” Elec Field" ，  "impact_elec_rate" ，

"impact_hole_rate"，"impact_ionization"这几个变量进行查看时，可以选择

在屏幕上显示该变量的最大值以及最大值所在的位置，缺省情况下不显示，可以

选择菜单项 Option->Show “Max…” Label 打开显示开关： 

 

1.2.3.17 界面介绍>菜单项说明>Option Menu>Parameter Max and Min 

Display 

该选项用于显示当前变量的最大值和最小值以及所在的坐标位置，如下图所示： 
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1.2.3.18 界面介绍>菜单项说明>Option Menu>1D Multiple-Cut Line 

该菜单项功能与常用工具栏按钮->1D Cut 功能类似，都是在 2d contour fill

上进行 cut，唯一的不同是 1D Cut 每次只能产生一条 cut 线，而 1d 

multiple-cut line 可以一次产生多条 cut 线。操作方法是先选中菜单项 

Option->1D Multiple-Cut line，然后点击工具栏按钮 1D Cut，用鼠标在屏幕

上拖动产生多条 cut 线，如下图所示： 
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在终点处双击鼠标，然后产生 cut line： 
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1.2.3.19 界面介绍>菜单项说明>Option Menu>Show 3D View of 2D 

Contour 

在三维坐标系里显示二维 contour 面，从而能更直观地反应当前 2d plane 在整

个器件中的位置。如下图所示的带有曲面的三维器件： 
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当我们选中菜单项 option->Show 3D View of 2D Contour 以后，在工具栏面

板的 2D ZPlanes View 中选择不同的 2d plane 进行查看，可以看到二维的

contour fill 被显示在三维坐标系中，如下图显示的分别是 plane 4 和 plane 11

的 contour fill ： 
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1.2.4 界面介绍>菜单项说明>Tools Menu 

1.2.4.1 界面介绍>菜单项说明>Tools Menu>Set Display Property 

1）Set Rotate Degree 

对三维物体分别设置 x,y 和 z 方向上的旋转角度，在对话框中输入相应的旋转角

度，然后点击”ok”，物体就会根据设置的角度做出相应的旋转。 

 

 

2）Set Plot Resolution 

该菜单项用来在显示 3d surface fill 的时候设置 x,y 和 z 方向上 cut 线的数量，

缺省值为 50，cut 线越多得到的结果越精确。如以下显示的是 x 和 y 方向上的

cut line num=20 的 surface fill 的效果： 
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如果在 set plot resolution 对话框中把 cut line 数量改成 50： 
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则得到的结果如下： 

 

 

可 以 明 显 感 觉 到 数 据 的 精 度 得 到 了 提 高 ， 我 们 可 以 点 击 菜 单 项

View->Structural Data->3D Surface Grid，把线框显示去掉，从而能使两张

图的结果进行更好的对比，以下分别为 cut line num=20, 50 和 100 时候的显

示效果： 
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3）Set View Point / Angle 

该菜单项用来设置透视投影时物体和视点之间的距离，以及透视投影的角度，只

有当三维物体的投影方法为 perspective view 时才适用，平行投影(parallel 

view)时不适用。详见菜单项 Option->Perspective View & Parallel View. 

4）Set Color Scale 

该功能和工具栏面板中的 Set Color Range 功能类似，用于对变量值范围进行

重新设置。详见常用工具栏按钮->Set Color Range. 

5）Set Color Range 

Set Color Range 和 Set Color Scale 的功能不同，Set Color Range 用来设置

颜色范围的最大和最小值，而 Set Color Scale 是对变量值范围进行重新设定。

如下图所示的对话框中代表最大值的颜色为红色，代表最小值的颜色为蓝色，这

也是目前 Crosslightview 采用的缺省颜色： 
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如果我们在对话框中选择不同的颜色值范围，如最小值为浅蓝色，最大值为橘色： 

 

 

则会得到如下的显示效果： 



 

 

第 189 页 共 238 页 

第 189 页 共 238 页 

 

 

Set Color Range 对话框中还有一个功能是修改颜色的层数（level num），在

缺省情况下 Crosslightview 将 color level num 设为 20，用户也可以自由设置

颜色层数，从而得到更细腻的显示效果，如下图显示的是颜色层数分别为 20 和

50 的效果对比图： 
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                         Level num = 20 
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                          Level num = 50 

在 Color Level Num 文本框中还有一个 continuous color 复选框，如果选中则

表示使用连续颜色值进行显示，如上图所示的例子如果用 continuous color 来

显示则显示效果如下： 

 

可以看到当前的颜色变化仅在红蓝色系之间变化，没有其他色系的颜色，该功能

类似于 property->color bar->use gray color 中的灰度阶梯颜色表示，用户可

以根据需要选择自己想要的颜色表现方式。 

6）Set Relative Vector Size 

当绘制 Vector Plot 矢量图的时候，用来设置相对矢量长度从而控制矢量分布的

密度。详见菜单项说明->View Menu->Vector Plot. 

7）Set Transparency Ratio 

设置材料的透明度（0-1.0 之间），缺省为 0.4，具体设置方法请参见界面布局->
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材料列表中的 5)材料透明度。 

1.2.4.2 界面介绍>菜单项说明>Tools Menu>Set Plot Property 

该菜单项的功能和工具栏按钮 Property 的功能一样，用来设置 Axis，Mesh Line

等绘制属性。详见常用工具栏按钮->Property. 

1.2.4.3 界面介绍>菜单项说明>Tools Menu>Structure Data Property 

用来设置 mode_index, trap_index 等参数值，仅适用于 std 文件。以下图为例，

显示的是参数 wave_intensity 的 2d contour fill，在缺省情况下 modex_index 

= 1 ： 

 

如果想修改 modex_index 的值，可以点击菜单项 tools->structure_data 

property ，在对话框中输入 modex_index=2 ： 
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得到的是 wave_intensity 2 显示如下： 

 

其他可以设置的参数包括 trap_index，elec_conc_valley，hole_conc_valley，

elec_conc_subb，hold_conc_subb 等。 



 

 

第 194 页 共 238 页 

第 194 页 共 238 页 

1.2.4.4 界面介绍>菜单项说明>Tools Menu>Set Relation Plot 

该菜单项用来设置 scan bias 曲线的绘制方式，点击后出现如下对话框： 

 

 

1）Connection Points Method 

Connection points method 一栏里用来设置 scan bias 曲线上的点的连接方

式，缺省使用第一个选项“Only connect each point”，即相邻两个数据点逐

对连接，得到的结果显示如下： 
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如果选择第二个选项“Use Nurbs Method”，则会根据 scan bias 的数据点来

绘制 nurbs 样条曲线，如下图所示： 
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选项 3“Use Straight Line”用来绘制 scan bias 数据点的模拟斜率直线，如下

图所示： 

 

 

2）Draw L-I Line 
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“L-I Line” 选项在缺省状态下是关闭的（“Not draw L-I Line”），用户可以选

择 Use default y=ax+b 或者 Use manual y=ax+b 来设置 L-I 曲线的方程式，

L-I 曲线用蓝色线条绘制。例如对上面的例子如果选择显示 default L-I Lin 则显

示结果如下： 

 

1.2.4.5 界面介绍>菜单项说明>Tools Menu>Parameter Extraction 

Parameter Extraction 菜单用于在 scan bias 曲线里提取用户所需要的数据。

以上图中的 scan bias 曲线为例，假如我们点击 tools->Parameter Extraction

菜单项，弹出以下对话框，用户可以选择所需要的提取功能选项： 
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1）Vertical Intercept 

给出一个固定的横坐标值（x），计算位于 x 位置的垂直线段和 scan bias 曲线

的交点并在图上标出交点的位置。例如我们计算 x=0.01 处的交点为（x=0.01, 

y=-2.25429e-007）,显示在 scan bias 曲线中如下图所示： 
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2）Horizontal Intercept 

给出一个固定的纵坐标 Y 值，计算 y=-1e-006 与 scan bias 曲线的交点并显示

在屏幕上： 
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Scan bias 曲线分别与 x=0.01 以及 y=-1e-006 相交的交点 

 

3）Horizontal Fit Line 

指定一个横坐标区间（x from x1 to x2），计算该坐标区间内 scan bias line 的

斜率线并绘制在屏幕上： 
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4）Vertical Fit Line 

指定一个纵坐标区间（y from y1 to y2），计算该坐标区间内 scan bias line 的

斜率线并绘制在屏幕上： 
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5）XY Product Search 

指定一个 x 范围（from x1 to x2）和 y 的范围（y from y1 to y2），找到该范

围对应 scan bias 曲线上的 x 最大值和 y 最大值，并计算出 x 和 y 最大值覆盖

区域的面积（xy_product_max）。 
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6）Horizontal Max Search & Vertical Max Search 

找到横坐标和纵坐标的最大值并标出： 
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1.2.4.6 界面介绍>菜单项说明>Tools Menu>Set Scale Ratio 

该菜单项功能和常用工具栏面板中的 Axis Scale 相同，用来设置器件在屏幕上

显示的 x,y,z 方向上的缩放比例和缩放模式。详见常用工具栏按钮->Axis Scale. 

1.2.4.7 界面介绍>菜单项说明>Tools Menu>Set Scale Range 

设置 x,y,z 方向上的显示范围，功能和工具栏按钮面板中的“Region”类似，选

择一个局部区域放大显示。以下图为例： 

 

用户点击 tools->Set Scal Range 菜单项，在对话框中选择输入 x 范围从 0 - 5，

y 范围从 1 - 2.23 ： 
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点击 ok 按钮后，系统会根据用户选择的范围重新计算 mesh 并显示： 

 

 

1.2.4.8 界面介绍>菜单项说明>Tools Menu>Strcture Data Scale & 

Horizontal Axis Scale & Vertical Axis Scale 

这三个菜单项功能和常用工具栏按钮中的 log 相同，用来对参数值（contour fill）
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或坐标值（scan bias data）取 Log 运算。详见常用工具栏按钮->Log. 

 

1.2.4.9 界面介绍>菜单项说明>Tools Menu>Math Plot 

该菜单项用来对多个参数值进行数学运算，用户可以选择最多六个变量参数

（var1-var6）进行加法、减法、乘法、与常量相加（add a constant）、加基数

值（add a background）、取绝对值等运算，如下图对话框中所示，用户在进

行加法、减法和乘法运算前，需要先在对话框中选择需要进行数学运算的变量，

例如我们想计算 total_curr_x + total_curr_y 的值，先选择 Addition 选项，在 

var1 下拉框中选择”total_curr_x”，然后在 var4 下拉框中选择”total_curr_y”，

点击”ok”按钮就会得到 total_curr_x+total_curr_y 的 contour fill 的显示： 
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1.2.4.10 界面介绍>菜单项说明>Tools Menu>Insert Panels & Delete 

Added Panels 

当使用 color box 方法连接 Z 方向上的 xy plane 时（关于 color box 的解释可

参见常用工具栏按钮->Z-Connect），z 方向上的颜色会呈现不自然的锯齿状的

过渡，如下图所示： 

 

 

 

为了解决这个问题，我们可以在相邻两个 xy plane 之间插入更多的面，使得颜

色的过渡显得更缓和自然，这时可以点击菜单项 tools->Insert Panels，在对话

框中输入想要插入的 plane 的数量，例如我们输入 5，表示在相邻两个 xy 原始

面之间插入 5 个面： 
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点击“ok”后得到的结果如下，可以明显感觉到颜色的过渡变得平滑自然了： 

 

 

用户可以根据需要调整插入面的数量，来达到期望的显示效果。 

在使用 insert panels 插入一定数量的面之后，用户也可以选择菜单项 Delete 

inserted panels 来删除插入的面，回到最初的显示状态。 

1.2.4.11 界面介绍>菜单项说明>Tools Menu>Set Cylinder Degree 

对 于 cylindrical 圆 柱 体 器 件 ， 如 果 输 出 文 件 中 只 给 出 一 个 面 的 数 据 ，

crosslightview 会自动将这个面拓展成三维圆柱体，缺省的拓展角度为 60 度，
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如下图所示的器件： 

 

 

用户可以通过菜单项 tools->Set Cylinder Degree 来调整圆柱体展开的角度，

在对话框中输入从 0-360 度之间的任意一个角度并点 OK 按钮： 

 

 

 

上图所示的例子在扩展到 90 度以后显示如下： 
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1.2.4.12 界面介绍>菜单项说明>Tools Menu>FDTD Control Parameters 

用来设置 FDTD 的一些参数变量，关于 FDTD 的绘制可以参见菜单项说明 File 

Menu->File Open->FDTD View. FDTD 的参数设置主要包括以下三类： 

1）Primary Settings 

Primary Settings 面板中的参数和.sol 文件中的 fdtd_model 模块相对应： 
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其中 field monitor location 与.sol 文件中的 fdtd_fieldmonitor 中的数据相对

应： 

 

 

2）Boundary Condition 
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用 来 设 置 PML 的 厚 度 和 边 界 范 围 。 该 部 分 参 数 与 fdtd_model 中 的

PML_thickness 和 boundary_type 等数据相对应。 

 

 

1.2.5 界面介绍>菜单项说明>Windows Menu 

1.2.5.1 界面介绍>菜单项说明>Windows Menu>窗口布局 

窗 口 布 局 包 括 三 个 菜 单 项 window->Cascade, Tile Horizontally, Tile 

Vertically，分别表示将目前所有的窗口进行层叠排列、水平对齐和垂直对齐排
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列，如下图所示： 

 

                  窗口排列方式 – Cascade 

 

                     窗口排列方式 – Tile Horizontally 
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1.2.5.2 界面介绍>菜单项说明>Windows Menu>Status Bar 

通过选中或取消选中该菜单项来显示或隐藏屏幕下方的状态栏。 

1.2.5.3 界面介绍>菜单项说明>Windows Menu>Full Screen View 

设置全屏显示模式。 

 

1.2.5.4 界面介绍>菜单项说明>Windows Menu>Switch to Old GUI 

切 换 到 crosslightview 的 老 版 本 界 面 ， 效 果 等 同 于 直 接 打 开 \GUI\ 

CrosslightView_old.exe. 

第二部分 工艺仿真结果查看 

2.1 工艺仿真结果查看>打开二维和三维结构(.str) 

有两种方法可以打开查看 str 文件的结构，一种方法是点击屏幕左上方的常
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用工具栏按钮->Open Str File 按钮 ，在对话框中选择想要查看的 str 文

件并点击“打开”按钮： 

 

 

另一种方法是点击菜单项 File->File Open->Process Directory，在选择文

件对话框中选择文件类型后缀 Str Files(*.str)，并在文件列表中选择相应的 str 

文件： 
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以下显示的分别是二维和三维结构的 str 器件（分别由三角形 mesh，坐标

轴， 材料列表等部分组成）： 

 

                  二维 str 文件 
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三维 str 文件 

 

2.2 工艺仿真结果查看>二维三维变量分布（掺杂浓度） 

当用户打开 str 文件以后，屏幕右方的变量参数列表里会列出当前 str 文件

中的所有参数变量名称，如下图所示： 
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用户可以点击列表中任意一个变量来查看它的分布图，比如针对 2.1 中的三

维 str 文件我们在列表中选择变量 p_doping 进行查看，得到的显示结果如下： 

 

 

同样针对二维的 str 文件我们也可以使用相同的方法查看变量浓度的分布： 
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2.3 工艺仿真结果查看>1D Cut Line 

绘制 1D Cut Line 共分三种情况： 

1） 绘制单个参数变量在 xy contour 上的 cut line 

可以点击工具栏按钮>1D Cut，具体操作方法请参见常用工具栏按钮->1D 

Cut； 

2） 同时绘 制 多个变 量 在 xy contour 上 的 cut line， 点击 菜单项 View 

Data->Multiple-variables 1D Cut，具体操作方法请参见菜单项说明 View 

Data->Multiple-variables 1d cut. 

3） 绘制单个变量在 Z 方向上的 cut line，点击菜单项 View Data->1D Cut in Z 

Direction。具体操作方法请参见菜单项说明 View Data->1D Cut in Z 

Direction. 

 

2.4 工艺仿真结果查看>数据导出 

参见菜单项说明->File Menu->Export. 

第三部分 器件仿真结果查看 

3.1 器件仿真结果查看>打开二维和三维结构(.std) 

有三种方法可以打开查看 std 文件的结构: 

方法一：点击屏幕左上方的常用工具栏按钮->Open Std File 按钮 ，
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在对话框中选择想要查看的 std 文件并点击“打开”按钮： 

 

 

方法二：点击菜单项 File->File Open->Process Directory，在选择文件对

话框中选择文件类型后缀 Std Files(*.std)，并在文件列表中选择相应的 std 文

件： 

 

 

 

方法三：点击菜单项 File->File Open->Device Directory： 
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 选择 std 文件所在的项目文件夹： 
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在该项目文件夹下的所有 std 文件列表中选择一个进行查看： 

 

 

 

以下显示的分别是二维和三维结构的 std 器件（分别由三角形 mesh，坐标

轴， 材料列表等部分组成）： 

 

三维 std 器件结构图 
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                 二维 std 器件结构图 

 

 

3.2 器件仿真结果查看>二维三维变量分布（能带，电子浓度等） 

当用户打开 std 文件以后，屏幕右方的变量参数列表里会列出当前 std 文件

中的所有参数变量名称，如下图所示： 
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一些主要或常用的变量被放在“Primary”一栏里，而其他一些不太常用的

变量放在“Secondary”一栏里。用户可以点击列表中任意一个变量来查看它的



 

 

第 230 页 共 238 页 

第 230 页 共 238 页 

分 布 图 ， 比 如 针 对 3.1 中 的 三 维 std 文 件 我 们 在 列 表 中 选 择 变 量

conduction_band 进行查看，得到的显示结果如下： 

 

 

同样针对二维的 std 文件我们也可以使用相同的方法查看变量浓度的分布，

如下图所示的是 3.1 中的二维器件在 Potential 上的分布： 
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3.3 器件仿真结果查看>1D Cut Line 

绘制 1d cut line 的方法和前面介绍的 str 文件的 cut line 操作方法相同，具

体可参见工艺仿真结果查看->1D Cut Line. 

3.4 器件仿真结果查看>I-V 曲线 

I-V 曲线也就是前面所提到的 scan bias 曲线，用户可以通过点击工具栏按

钮->scan bias 或者菜单项 view->scan bias 来绘制 I-V 曲线，具体方法可以参

见常用工具栏按钮->Scan Bias 或者菜单项说明->View Data Menu->Scan 

bias Data。 
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3.5 器件仿真结果查看>查看.plt 脚本结果 

使用菜单项 File->File Open ->Process Directory，在打开文件对话框中

选择.plt 后缀名，然后在文件列表中选择想要查看的 plt 文件： 

 

 

 

 

 

选择 plt 文件后弹出一个对话框，里面列出了该 plt 文件中的所有图形列表，
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如下图所示（plt plot 1 – plot n），每一个 Plot 代表一个图形，如 I-V 曲线， 

参数分布图等。 

 

可以在对话框中选择单个或多个图形进行显示，点击“Plot Selected”绘制

用户选择的图形，或点击“Plot All”绘制 plt 文件里所有的图形。选择完毕后

系统会调用核心程序（如 Apsys.exe）来处理 plt 文件，用户可以在弹出的 DOS

命令窗口中看到这个处理过程： 
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产生的最终结果调用 gnuplot.exe 进行显示，如下图所示： 
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第四部分 高级功能 

4.1 高级功能>翻转图形 

有两种方法可以将显示的图形在 X 和 Y 方向上进行翻转： 

方法一：点击菜单项 Option->Flip X Axis / Flip Y Axis 

方法二：工具栏按钮 Property->Axis Property->Flip Axis 

这两种方法的使用效果是一样的，具体操作方法可以参见常用工具栏按钮

Property->Axis Property. 

4.2 高级功能>变量搜索 

当一个文件的参数变量较多时（尤其是 std 文件），如果用户想要迅速查找
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到某个特定的变量进行查看，可以使用 Crosslightview 中提供的变量名快速匹

配查找功能，方法是在屏幕右方的参数列表上方的搜索文本框中输入变量名关键

字，系统会根据关键字迅速查找所有符合该关键字的变量名并在列表中显示供用

户选择。具体操作方法请参见界面布局->变量参数列表。 

4.3 高级功能>log 和 linear 切换 

对于结果值取 log 或 linear 的方法可以参见前面介绍过的界面布局->常用

工具栏按钮->Log。 

4.4 高级功能>三维切面 

对于三维的变量分布，我们可以在 xy,yz 和 xz 三个方向上对 3d cubic 

contour fill 进行 cut，具体 cut 方法可以参见常用工具栏按钮->2D Cut. 

4.5 高级功能>多图合并 

参见菜单项说明->View Data->Combined Plots. 

4.6 高级功能>曲线的自由缩放 

在显示 scan bias 或 band diagram 曲线时，用户有时想要查看局部放大区

域的细节展示图，这时候就要用到工具栏按钮中的 region 按钮来选取局部区域

进行放大，具体操作方法可参见常用工具栏按钮->Region 或者菜单项说明

->Option->Select Region。 
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4.7 高级功能>材料的选择性显示 

对于器件的材料分布显示，用户可能想要暂时关闭或打开某一种或几种材料

的显示，如下图所示的三维器件： 

 

 

如果我们想要隐藏材料 inp，需要在屏幕左下方的材料列表里将 inp 的勾选

状态取消，如下图所示： 

 

 

得到的显示结果如下，inp 材料被隐藏起来了，我们看以清楚地看到另外两

种材料的内部结构： 
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